aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nlmon
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-03-09 13:04:38 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-06 20:01:07 +0000
commit6e5e98c6718925240898842fc0289ee23add9cd4 (patch)
tree7b93442bad99efdb680fd712f5f9851c81f16ab7 /testing/nlmon
parentb3e6b40755025662af3f4b8b3230559882a0cae9 (diff)
downloadaports-6e5e98c6718925240898842fc0289ee23add9cd4.tar.bz2
aports-6e5e98c6718925240898842fc0289ee23add9cd4.tar.xz
testing/nlmon: new aport
Diffstat (limited to 'testing/nlmon')
-rw-r--r--testing/nlmon/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/nlmon/APKBUILD b/testing/nlmon/APKBUILD
new file mode 100644
index 0000000000..8d426a6e3c
--- /dev/null
+++ b/testing/nlmon/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=nlmon
+pkgver=0.3_git20160208
+pkgrel=0
+verbase=0.3
+pkgdesc="A lightweight udevadm monitor replacement"
+url="http://git.r-36.net/nlmon/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
+
+disturl="dev.alpinelinux.org:/archive/$pkgname"
+reporev="5881cff90359800b1d01ebc0bf35f53f4a67815d"
+giturl="git://git.r-36.net/$pkgname"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ make CFLAGS="$CFLAGS \${INCS} \${CPPFLAGS}" \
+ LDFLAGS="$LDFLAGS \${LIBS}" CC="${CC:-gcc}" \
+ -C "$_builddir" || return 1
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr \
+ -C "$_builddir" install || return 1
+}
+
+md5sums="79cc3840879d6370aa5adccc97c7acf2 nlmon-0.3_git20160208.tar.gz"
+sha256sums="e9e113d344372c7b9d8321f6fa19a35b190e2989bbda9a005a049b499faef11a nlmon-0.3_git20160208.tar.gz"
+sha512sums="581cb69224552fe293f3ed2da783223570e19d84cbab5c12479cf48088522b9a1d565626d1c24690cb2464858f34cfa9595830395e70f36056ab71631afad3a0 nlmon-0.3_git20160208.tar.gz"