aboutsummaryrefslogtreecommitdiffstats
path: root/testing/numactl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-07 20:24:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-07 20:24:29 +0100
commit2f7ca837e984144528c878da5d6547d38e13c426 (patch)
tree565a9d2d630aebe632b8b3ab1f02db0de4c66d16 /testing/numactl
parent94b0d6efc9aacb8a4ccb08e9bb6359e6d8181dfc (diff)
downloadaports-2f7ca837e984144528c878da5d6547d38e13c426.tar.bz2
aports-2f7ca837e984144528c878da5d6547d38e13c426.tar.xz
testing/numactl: fix project url and source
The original sites are dead.
Diffstat (limited to 'testing/numactl')
-rw-r--r--testing/numactl/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/numactl/APKBUILD b/testing/numactl/APKBUILD
index 5694a10a49..8ce695a01f 100644
--- a/testing/numactl/APKBUILD
+++ b/testing/numactl/APKBUILD
@@ -1,20 +1,26 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=numactl
pkgver=2.0.11
-pkgrel=2
+pkgrel=3
pkgdesc="Simple NUMA policy support"
-url="http://oss.sgi.com/projects/libnuma/"
+url="https://github.com/numactl/numactl"
# ARM lacks the __NR_migrate_pages syscall
arch="all !armhf"
license="GPL2 LGPL2"
-depends=""
-makedepends="linux-headers"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-tools:_tools"
+makedepends="autoconf automake libtool linux-headers"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
options="!check"
-source="ftp://oss.sgi.com/www/projects/libnuma/download/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/numactl/$pkgname/archive/v$pkgver.tar.gz
musl.patch"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ ./autogen.sh
+}
+
build() {
cd "$builddir"
./configure \
@@ -31,12 +37,12 @@ package() {
rm -r "$pkgdir"/usr/share/man/man2
}
-_tools() {
+tools() {
pkgdesc="NUMA policy control tools"
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="1969d7ee0ff3de0d6f1fa42ec089a17cdb3f92cb35d453b8f8b2eec49724c43787ecbd213357013a8f2500a260b0df9844d515815ca3a0376314a0eed050a0d4 numactl-2.0.11.tar.gz
+sha512sums="610c9b5fee8d1d1a6ff4117c96eedff48d3a047a115abfe7819f98664aff61bc0f694efc49eaee3f9b6135c057b4365d4cce1bcc38dd2094055d61df5efbb1e2 numactl-2.0.11.tar.gz
c24affa5a8a8ea83d7f0ee384dc0629e17a5c4201357132f770f894ad4236772116d96d8389d54fb99095af40d1ccbffc3170b5fb9cc88cfca39179f50bee9c9 musl.patch"