aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-merlin-extend
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-05 11:44:04 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-05 13:20:24 +0100
commit9759536b15c14d8d6949bae519572f58aefdee51 (patch)
tree9e650276a4d22f278493be7d11a716878b7c65eb /testing/ocaml-merlin-extend
parent585b637d1231ac39dd35cadeb0a5cb41ec78b3ce (diff)
downloadaports-9759536b15c14d8d6949bae519572f58aefdee51.tar.bz2
aports-9759536b15c14d8d6949bae519572f58aefdee51.tar.xz
testing/ocaml-merlin-extend: new aport
https://github.com/let-def/merlin-extend SDK to extend Merlin
Diffstat (limited to 'testing/ocaml-merlin-extend')
-rw-r--r--testing/ocaml-merlin-extend/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/ocaml-merlin-extend/APKBUILD b/testing/ocaml-merlin-extend/APKBUILD
new file mode 100644
index 0000000000..fe66f54497
--- /dev/null
+++ b/testing/ocaml-merlin-extend/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ocaml-merlin-extend
+_pkgname=merlin-extend
+pkgver=0.3
+pkgrel=0
+pkgdesc="SDK to extend Merlin"
+url="https://github.com/let-def/merlin-extend"
+arch="all !x86 !armhf !s390x !ppc64le" # limited by ocaml and ocaml-cppo aports
+license="MIT"
+makedepends="ocaml ocaml-cppo ocaml-findlib"
+options="!check" # no tests provided
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/let-def/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ export OCAMLFIND_DESTDIR="$pkgdir/usr/lib/ocaml"
+ mkdir -p "$OCAMLFIND_DESTDIR"
+ make install
+}
+
+dev() {
+ default_dev
+ depends="$pkgname=$pkgver-r$pkgrel"
+ local sitelib="usr/lib/ocaml/${_pkgname/-/_}"
+
+ cd "$pkgdir"/$sitelib
+
+ mkdir -p "$subpkgdir"/$sitelib
+ mv *.cmxa *.ml *.mli "$subpkgdir"/$sitelib/
+}
+
+sha512sums="1e6436299b38c7fa57ae5b681a1409795545bc6f5956d6b1c37cbfdbdabfd90da476c030067fe2e016c823d60d1e5498c4536c869bf58425e1a6ff78295efba4 ocaml-merlin-extend-0.3.tar.gz"