aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-re
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:25:15 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:29 +0200
commitdcae868bf8a795b49de5ce479ac7988239ed9722 (patch)
treebb381a3af924c744729dcab1f652d70e25ed9bc0 /testing/ocaml-re
parent71209d0a482684c0bab9add2c3b35fd581b0aee7 (diff)
downloadaports-dcae868bf8a795b49de5ce479ac7988239ed9722.tar.bz2
aports-dcae868bf8a795b49de5ce479ac7988239ed9722.tar.xz
testing/ocaml-re: upgrade to 1.7.3 and improve abuild
Diffstat (limited to 'testing/ocaml-re')
-rw-r--r--testing/ocaml-re/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/testing/ocaml-re/APKBUILD b/testing/ocaml-re/APKBUILD
index 2b05d5948a..86199d3deb 100644
--- a/testing/ocaml-re/APKBUILD
+++ b/testing/ocaml-re/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-re
-pkgver=1.7.2
+pkgver=1.7.3
pkgrel=0
pkgdesc="Pure OCaml regular expressions, with support for Perl and POSIX-style strings"
url="https://github.com/ocaml/ocaml-re"
@@ -39,22 +39,26 @@ package() {
rm -Rf usr/doc
# Remove annotation files and sources.
- find usr/lib/ocaml \
- \( -name '*.cmt' -o -name '*.cmti' -o -name '*.ml' \) \
- -a -delete
+ find usr/lib/ocaml \( \
+ -name '*.cmt' -o \
+ -name '*.cmti' -o \
+ -name '*.ml' \) -delete
}
dev() {
- local sitelib="usr/lib/ocaml/re"
default_dev
cd "$pkgdir"
- local path
- for path in $(find $sitelib -name '*.cmx' -o -name '*.cmxa' -o -name '*.mli'); do
+ local path; for path in $(find usr/lib/ocaml/re \
+ -name '*.cmx' -o \
+ -name '*.cmxa' -o \
+ -name '*.mli')
+ do
mkdir -p "${path%/*}"
mv "$path" "$subpkgdir"/${path%/*}/
done
+
}
-sha512sums="d8820aed7728ba5d195b1db5135281b1c95bbcd105800e52ca2efb1637b2b251e3b5e1b14dadc212b87f2ec5e7af0bfe3e9244b13e905433240cd34c102029c2 ocaml-re-1.7.2.tar.gz"
+sha512sums="3d161cb46fa0e855bfbae29b5b769f0054b51e4021f8a66ff8d6a9eee257ba4b02ab7202337d35c4ed2a033560a7b69676525f32cb18406881bed2e68db2ca55 ocaml-re-1.7.3.tar.gz"