aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-react
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 01:46:45 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:26 +0100
commit6e0bf7f5a3070c783ac56f4d005d83b3830aaeb8 (patch)
tree2c14ff7e74f4ce43bcf7b0e58c03da029f918ed5 /testing/ocaml-react
parente62a10dcc80807932ea8b7f78ebc70117a5be640 (diff)
downloadaports-6e0bf7f5a3070c783ac56f4d005d83b3830aaeb8.tar.bz2
aports-6e0bf7f5a3070c783ac56f4d005d83b3830aaeb8.tar.xz
testing/ocaml-react: rebuild with ocaml 4.06.1, fix depends
Diffstat (limited to 'testing/ocaml-react')
-rw-r--r--testing/ocaml-react/APKBUILD11
-rw-r--r--testing/ocaml-react/fix-safe-string.patch18
2 files changed, 25 insertions, 4 deletions
diff --git a/testing/ocaml-react/APKBUILD b/testing/ocaml-react/APKBUILD
index 9b512a0e8d..dd9d0dae16 100644
--- a/testing/ocaml-react/APKBUILD
+++ b/testing/ocaml-react/APKBUILD
@@ -3,15 +3,17 @@
pkgname=ocaml-react
_pkgname=react
pkgver=1.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml framework for Functional Reactive Programming (FRP)"
url="http://erratique.ch/software/react"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
license="ISC"
-makedepends="ncurses ocaml ocaml-findlib ocamlbuild opam"
+depends="ocaml-runtime"
+makedepends="ncurses ocaml ocaml-compiler-libs ocaml-findlib ocamlbuild opam"
options="textrels" # needed for ppc64le
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz
+ fix-safe-string.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -54,4 +56,5 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="929f0a5e84d6e92c366e3c43c582c48e639eab662f654ff65b4789155e96ce4bdd10c38acfb932a20ddce4042943baa2644934be4d7542a20b801203437c3d21 ocaml-react-1.2.0.tar.gz"
+sha512sums="929f0a5e84d6e92c366e3c43c582c48e639eab662f654ff65b4789155e96ce4bdd10c38acfb932a20ddce4042943baa2644934be4d7542a20b801203437c3d21 ocaml-react-1.2.0.tar.gz
+8ac6aa6f703ab866abcae0640f539a9eb0f2796713306191d308f6988b186514dd3a5b70197a56ef6f83d62d5d179d2210241e001b8a944f5272757326e978fc fix-safe-string.patch"
diff --git a/testing/ocaml-react/fix-safe-string.patch b/testing/ocaml-react/fix-safe-string.patch
new file mode 100644
index 0000000000..5a9ee3e2a5
--- /dev/null
+++ b/testing/ocaml-react/fix-safe-string.patch
@@ -0,0 +1,18 @@
+Fix for compatibility with ocaml >=4.06
+
+Patch-Source: https://src.fedoraproject.org/rpms/ocaml-react/blob/f28/f/react-1.2.0-safe-string-fix.patch
+
+--- a/test/breakout.ml
++++ b/test/breakout.ml
+@@ -136,9 +136,9 @@
+ let time, send_time = E.create ()
+ let key, send_key = E.create ()
+ let gather () = (* updates primitive events. *)
+- let c = " " in
++ let c = Bytes.of_string " " in
+ let i = Unix.stdin in
+- let input_char i = ignore (Unix.read i c 0 1); c.[0] in
++ let input_char i = ignore (Unix.read i c 0 1); Bytes.get c 0 in
+ let dt = 0.1 in
+ while true do
+ if Unix.select [i] [] [] dt = ([i], [], []) then send_key (input_char i);