aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openmpi
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2017-09-11 22:58:15 -0400
committerDaniel Sabogal <dsabogalcc@gmail.com>2017-09-19 19:27:14 -0400
commit2d434cd069190d09262209183beaa2366d6f8b4d (patch)
treee4e88bcb9c973ab0e35aaa323e8d20c323a6fdae /testing/openmpi
parentff26b3024520d4eb359cb299af74009188c2ea6e (diff)
downloadaports-2d434cd069190d09262209183beaa2366d6f8b4d.tar.bz2
aports-2d434cd069190d09262209183beaa2366d6f8b4d.tar.xz
testing/openmpi: upgrade to 2.1.2
Diffstat (limited to 'testing/openmpi')
-rw-r--r--testing/openmpi/APKBUILD44
-rw-r--r--testing/openmpi/include-unistd.patch21
2 files changed, 50 insertions, 15 deletions
diff --git a/testing/openmpi/APKBUILD b/testing/openmpi/APKBUILD
index 97572da934..1760d1b9ec 100644
--- a/testing/openmpi/APKBUILD
+++ b/testing/openmpi/APKBUILD
@@ -1,16 +1,15 @@
-# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
-# Maintainer:
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=openmpi
-pkgver=2.0.2
+pkgver=2.1.1
pkgrel=0
pkgdesc="Message passing library for high-performance computing"
url="https://www.open-mpi.org/"
arch="all"
license="BSD"
-depends=""
-makedepends="perl hwloc-dev libgomp"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/$pkgname-$pkgver.tar.bz2"
+makedepends="perl gfortran hwloc-dev libevent-dev libgomp"
+subpackages="$pkgname-dev:_dev $pkgname-doc"
+source="https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/$pkgname-$pkgver.tar.bz2
+ include-unistd.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -19,18 +18,33 @@ build() {
--prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc/$pkgname \
+ --enable-mpi-fortran=all \
+ --enable-mpi-cxx \
--enable-ipv6 \
- --with-hwloc=/usr \
--with-threads=posix \
- || return 1
- make || return 1
+ --with-hwloc=/usr
+ make
+}
+
+check() {
+ make -C "$builddir" check
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make -C "$builddir" DESTDIR="$pkgdir" install
+}
+
+_dev() {
+ default_dev
+
+ local bins="mpiCC mpic++ mpicc mpicxx mpif77 mpif90 mpifort
+ ortecc opal_wrapper oshcc oshfort shmemcc shmemfort"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ local i; for i in $bins; do
+ mv "$pkgdir"/usr/bin/$i "$subpkgdir"/usr/bin
+ done
}
-md5sums="ecd99aa436a1ca69ce936a96d6a3fa48 openmpi-2.0.2.tar.bz2"
-sha256sums="cae396e643f9f91f0a795f8d8694adf7bacfb16f967c22fb39e9e28d477730d3 openmpi-2.0.2.tar.bz2"
-sha512sums="87dc3c23db4b9cb92dbacc9b384b21ce8c4288fe4edc204fbf4a3bef70d8ac4329269e777ed190fa87933d78b73b9e5550ea3b925b2039599cfef3953567232a openmpi-2.0.2.tar.bz2"
+sha512sums="c11bba6ec815f9c8d32fce3578f8995f6cd694e02fb850d7e6cd3975989bb38fdbef348064264a1de418d0a21411c70ca74347ecff4f27eb5a2f6835019d6bca openmpi-2.1.1.tar.bz2
+5f4720e3d078c4e6938c0c970972c9ab574e37aebc31bebd9fb2a2712020c6bf6b4e366e6a75ed23c4568a8c2b3b3a2fa3b8407edb6ec1629e2c242403edd103 include-unistd.patch"
diff --git a/testing/openmpi/include-unistd.patch b/testing/openmpi/include-unistd.patch
new file mode 100644
index 0000000000..e7add10edf
--- /dev/null
+++ b/testing/openmpi/include-unistd.patch
@@ -0,0 +1,21 @@
+--- openmpi-2.1.1/opal/include/opal/sys/cma.h.orig
++++ openmpi-2.1.1/opal/include/opal/sys/cma.h
+@@ -28,7 +28,7 @@
+ #endif
+
+ #ifdef HAVE_UNISTD_H
+-#include <sys/unistd.h>
++#include <unistd.h>
+ #endif
+
+ #ifdef __linux__
+--- openmpi-2.1.1/opal/mca/pmix/pmix112/pmix/include/pmix/pmix_common.h.orig
++++ openmpi-2.1.1/opal/mca/pmix/pmix112/pmix/include/pmix/pmix_common.h
+@@ -51,6 +51,7 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <sys/time.h> /* for struct timeval */
++#include <unistd.h>
+
+ #include <pmix_version.h>
+