aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pacparser/spidermonkey-make.patch
diff options
context:
space:
mode:
authorAaron Hurt <ahurt@anbcs.com>2016-06-10 09:12:11 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-06-11 17:05:01 +0200
commit4e051e1e7a83787c77db255b7cb24b017419f857 (patch)
tree206017549c25b1a6fa856940cc750ed31b960f14 /testing/pacparser/spidermonkey-make.patch
parent0291d3f23c45addb9aa436ae4bcb4f0d25a684f8 (diff)
downloadaports-4e051e1e7a83787c77db255b7cb24b017419f857.tar.bz2
aports-4e051e1e7a83787c77db255b7cb24b017419f857.tar.xz
testing/pacparser: new aport
http://pacparser.manugarg.com A library to parse proxy auto-config (PAC) files
Diffstat (limited to 'testing/pacparser/spidermonkey-make.patch')
-rw-r--r--testing/pacparser/spidermonkey-make.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/pacparser/spidermonkey-make.patch b/testing/pacparser/spidermonkey-make.patch
new file mode 100644
index 0000000000..a56bd6de7a
--- /dev/null
+++ b/testing/pacparser/spidermonkey-make.patch
@@ -0,0 +1,22 @@
+The find command used in the upstream Makefile copies identical files
+over eachother without forcing the copy. This patch adds the -f (force)
+option to the find copy command. This is not explicitly needed but does
+seem to reduce a warning.
+
+--- a/src/spidermonkey/Makefile
++++ b/src/spidermonkey/Makefile
+@@ -30,12 +30,12 @@
+
+ jslib: js-buildstamp
+ cd js/src
+- find . -name "libjs.a" -exec cp {} .. \;
++ find . -name "libjs.a" -exec cp -f {} .. \;
+
+ js-buildstamp:
+ mkdir -p js/src/$(OBJDIR)
+ CFLAGS="$(SMCFLAGS)" $(MAKE) -C js/src -f Makefile.ref libjs.a
+- find js/src -name "jsautocfg.h" -exec cp {} js/src \;
++ find js/src -name "jsautocfg.h" -exec cp -f {} js/src \;
+ touch js-buildstamp
+
+ clean: