aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-cgi-expand
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 10:38:58 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:23 +0300
commit2dc3ddcf8f14ae96de0121611e59c7aeae8cd46c (patch)
tree8b11fef32f1e1f42c2ad009bd37f2874040ce14c /testing/perl-cgi-expand
parenta632657b0af09fbfbe1dfb17d25ec3afb4a493b7 (diff)
downloadaports-2dc3ddcf8f14ae96de0121611e59c7aeae8cd46c.tar.bz2
aports-2dc3ddcf8f14ae96de0121611e59c7aeae8cd46c.tar.xz
testing/perl-cgi-expand: new aport
http://search.cpan.org/dist/CGI-Expand/
Diffstat (limited to 'testing/perl-cgi-expand')
-rw-r--r--testing/perl-cgi-expand/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-cgi-expand/APKBUILD b/testing/perl-cgi-expand/APKBUILD
new file mode 100644
index 0000000000..fa0500ff2e
--- /dev/null
+++ b/testing/perl-cgi-expand/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-cgi-expand
+_pkgreal=CGI-Expand
+pkgver=2.05
+pkgrel=0
+pkgdesc="convert flat hash to nested data using TT2's dot convention"
+url="http://search.cpan.org/dist/CGI-Expand/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-test-exception"
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BO/BOWMANBS/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="77905578fc9f7e9b030ab80d26fd85940f1fe550121d75432052e0e197183befa6ac229d380bbea19bca706ee498469f48a152d7cea2f746723e9470fe092ea3 CGI-Expand-2.05.tar.gz"