aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-crypt-saltedhash
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 11:34:15 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commitaf18a742d98eb20f84ca5941dd64861bf4e821b0 (patch)
treeeda8bac5bc0d6d7ae89f94e33cd8c0cf819d8233 /testing/perl-crypt-saltedhash
parentcb1e294ad95e33e97149e95c0684c91fe4190745 (diff)
downloadaports-af18a742d98eb20f84ca5941dd64861bf4e821b0.tar.bz2
aports-af18a742d98eb20f84ca5941dd64861bf4e821b0.tar.xz
testing/perl-crypt-saltedhash: new aport
http://search.cpan.org/dist/Crypt-SaltedHash/
Diffstat (limited to 'testing/perl-crypt-saltedhash')
-rw-r--r--testing/perl-crypt-saltedhash/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-crypt-saltedhash/APKBUILD b/testing/perl-crypt-saltedhash/APKBUILD
new file mode 100644
index 0000000000..aa0318d509
--- /dev/null
+++ b/testing/perl-crypt-saltedhash/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-crypt-saltedhash
+_pkgreal=Crypt-SaltedHash
+pkgver=0.09
+pkgrel=0
+pkgdesc="Perl interface to functions that assist in working with salted hashes"
+url="http://search.cpan.org/dist/Crypt-SaltedHash/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-test-fatal"
+cpancheckdepends="perl-test-fatal"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GS/GSHANK/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="8bb4fd840a387e1062b7c1d0106f59a4f3dab7de05cdf3a93566e8e8370a73695fae3531e7184c7542302c82f932015a8112b3a47cde2a332025a2b243133ac7 Crypt-SaltedHash-0.09.tar.gz"