aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-path-iter
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2018-01-06 16:35:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-27 17:43:25 +0000
commit0211a7b11bf19bdb0d5a4b5f9d5cd785c290ea6f (patch)
tree4762f1883e3e194d85c285cfd861c886de855df2 /testing/perl-path-iter
parentbd3d03d8d9056987d352c37c514cb9e8369a32b3 (diff)
downloadaports-0211a7b11bf19bdb0d5a4b5f9d5cd785c290ea6f.tar.bz2
aports-0211a7b11bf19bdb0d5a4b5f9d5cd785c290ea6f.tar.xz
testing/perl-path-iter: new aport
Diffstat (limited to 'testing/perl-path-iter')
-rw-r--r--testing/perl-path-iter/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-path-iter/APKBUILD b/testing/perl-path-iter/APKBUILD
new file mode 100644
index 0000000000..14aaf01db5
--- /dev/null
+++ b/testing/perl-path-iter/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=perl-path-iter
+_realname=Path-Iter
+pkgver=0.2
+pkgrel=0
+pkgdesc="Simple Efficient Path Iteration"
+url="http://drmuey.com/cpan_contact.pl"
+arch="noarch"
+license="PerlArtistic"
+depends=""
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DM/DMUEY/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="339f0c22e423cd4916324f02eac359ef3d6bc7718a49c1ad9384d1a0f4eabac3ddd3f1de2ad46beadbbc36473b18f137ad15171bb3e09cda68dd27f953042df4 Path-Iter-0.2.tar.gz"