aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-safe-isa
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 15:40:44 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commit8169f9cdf1d1d2d31f1d0615b9ce0459fc50054a (patch)
treea530f85c69bf8855ba660fab065013db17f26993 /testing/perl-safe-isa
parent4632fe15a4809fc5085910e4ac818a2795f4980c (diff)
downloadaports-8169f9cdf1d1d2d31f1d0615b9ce0459fc50054a.tar.bz2
aports-8169f9cdf1d1d2d31f1d0615b9ce0459fc50054a.tar.xz
testing/perl-safe-isa: new aport
Call isa, can, does and DOES safely on things that may not be objects http://search.cpan.org/dist/Safe-Isa/
Diffstat (limited to 'testing/perl-safe-isa')
-rw-r--r--testing/perl-safe-isa/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-safe-isa/APKBUILD b/testing/perl-safe-isa/APKBUILD
new file mode 100644
index 0000000000..771182f3d9
--- /dev/null
+++ b/testing/perl-safe-isa/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-safe-isa
+_pkgreal=Safe-Isa
+pkgver=1.000006
+pkgrel=0
+pkgdesc="Call isa, can, does and DOES safely on things that may not be objects"
+url="http://search.cpan.org/dist/Safe-Isa/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="2b6665fcd085969cfac48ca9079d89622480bfff055e4fc2817ff54ef1e15d2a3280f8455473a6922ae4e924f10c065b304a7733e4b1ab9f57cdbea26c7b552e Safe-Isa-1.000006.tar.gz"