aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-unit
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-04-15 02:42:41 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-04-27 05:46:11 +0000
commit83f5f5ff71d825935df80db5082daa03941f72ca (patch)
tree4de1b98904aeb9f9b6d2b8128115e216206dc084 /testing/perl-test-unit
parent333d21bb0ef88e99f40ce88a01b951954bd1e7d2 (diff)
downloadaports-83f5f5ff71d825935df80db5082daa03941f72ca.tar.bz2
aports-83f5f5ff71d825935df80db5082daa03941f72ca.tar.xz
testing/perl-test-unit: new aport
A unit testing framework http://search.cpan.org/dist/Test-Unit
Diffstat (limited to 'testing/perl-test-unit')
-rw-r--r--testing/perl-test-unit/APKBUILD51
-rw-r--r--testing/perl-test-unit/testcase.patch11
2 files changed, 62 insertions, 0 deletions
diff --git a/testing/perl-test-unit/APKBUILD b/testing/perl-test-unit/APKBUILD
new file mode 100644
index 0000000000..61b9376523
--- /dev/null
+++ b/testing/perl-test-unit/APKBUILD
@@ -0,0 +1,51 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=perl-test-unit
+_pkgreal=Test-Unit
+pkgver=0.25
+pkgrel=0
+pkgdesc="A unit testing framework"
+url="http://search.cpan.org/dist/Test-Unit/"
+arch="noarch"
+license="GPL PerlArtistic"
+options="!check"
+cpandepends="perl-class-inner perl-error perl-devel-symdump"
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MC/MCAST/$_pkgreal-$pkgver.tar.gz
+ testcase.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="8f76583c7480eec825080eb6cd94d1b1a1c7c3bc7f297607414c95777e9a9f880b5a0d927a41521389ae50c2ba1b9ec3d76149da47d5997add739970df6b154d Test-Unit-0.25.tar.gz
+d7e874a687f93347cb03b403b55a9a765caa38aed1f24c437c6e4a43d287084366aff5a97b4990487f00979288146a29d36989059c8e83b702824348c0f86bc5 testcase.patch"
diff --git a/testing/perl-test-unit/testcase.patch b/testing/perl-test-unit/testcase.patch
new file mode 100644
index 0000000000..9f28755591
--- /dev/null
+++ b/testing/perl-test-unit/testcase.patch
@@ -0,0 +1,11 @@
+--- a/lib/Test/Unit/TestCase.pm
++++ b/lib/Test/Unit/TestCase.pm
+@@ -103,7 +103,7 @@
+ my $class = ref($_[0]) || $_[0];
+ my @tests = ();
+ no strict 'refs';
+- if (defined(@{"$class\::TESTS"})) {
++ if (@{"$class\::TESTS"}) {
+ push @tests, @{"$class\::TESTS"};
+ }
+ else {