aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pg_cron
diff options
context:
space:
mode:
authorG.J.R. Timmer <gjr.timmer@gmail.com>2016-12-26 11:01:09 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-07 17:19:50 +0100
commitd1567cd92565fde357952208fce53e91fad7b291 (patch)
tree407b3c8e0ca15251b2a80a78ef5aa07fd8ca033f /testing/pg_cron
parent9b027cc1ebb0a0dea9fdb7c2a3becc4b109810a7 (diff)
downloadaports-d1567cd92565fde357952208fce53e91fad7b291.tar.bz2
aports-d1567cd92565fde357952208fce53e91fad7b291.tar.xz
testing/pg_cron: new aport
https://github.com/citusdata/pg_cron Cron-based job scheduler for PostgreSQL 9.5+ Review notes: Cleaned up APKBUILD, shorthened post-install message and claimed the contributor as maintainer. @jirutka
Diffstat (limited to 'testing/pg_cron')
-rw-r--r--testing/pg_cron/APKBUILD40
-rw-r--r--testing/pg_cron/pg_cron.post-install10
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/pg_cron/APKBUILD b/testing/pg_cron/APKBUILD
new file mode 100644
index 0000000000..6875968e64
--- /dev/null
+++ b/testing/pg_cron/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: G.J.R. Timmer <gjr.timmer@gmail.com>
+# Maintainer: G.J.R. Timmer <gjr.timmer@gmail.com>
+pkgname=pg_cron
+pkgver=1.0.0_rc1
+_pkgver=${pkgver/_rc/-rc.}
+pkgrel=0
+pkgdesc="Cron-based scheduler for PostgreSQL 9.5+"
+url="https://github.com/citusdata/pg_cron"
+arch="all"
+license="custom"
+depends="postgresql"
+makedepends="postgresql-dev"
+install="$pkgname.post-install"
+source="$pkgname-$pkgver.tar.gz::https://github.com/citusdata/$pkgname/archive/v$_pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$_pkgver"
+
+prepare() {
+ default_prepare || return 1
+ cd "$builddir"
+
+ # Remove -Werror from Makefile
+ # Required to compile on alpine, to ignore compilation warnings
+ sed "s/-Werror //" -i Makefile || return 1
+}
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+}
+
+md5sums="7aad687b7105df0de8f69b697e3ce317 pg_cron-1.0.0_rc1.tar.gz"
+sha256sums="0cd22063594c55f2b2042185b174a78b99bc70e3db6454c83eb92a9bdf6c8809 pg_cron-1.0.0_rc1.tar.gz"
+sha512sums="26ee5ada043458593baa966eae7be1cd9b51dd751d5f468261510327c6a42406b55ec45f01558f0dc3f374955f78fe1216b0d5c7d6bc66f45f092401612a9b72 pg_cron-1.0.0_rc1.tar.gz"
diff --git a/testing/pg_cron/pg_cron.post-install b/testing/pg_cron/pg_cron.post-install
new file mode 100644
index 0000000000..b8e13ba49f
--- /dev/null
+++ b/testing/pg_cron/pg_cron.post-install
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+cat <<EOF
+*
+* Add the following line to postgresql.conf and restart PostgreSQL:
+* shared_preload_libraries = 'pg_cron'
+*
+EOF
+
+exit 0