aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-memcached/APKBUILD
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-03-19 10:13:33 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-06 05:25:42 +0000
commitf4f745c9f92a7a4cdd5c25f10a2fb0c5cf9a3650 (patch)
tree3b2e06920c1c3da30e64c0b48c34c47c4a6052e9 /testing/php7-memcached/APKBUILD
parentcd9aa513b588fde6b32fa194edf22812358182ff (diff)
downloadaports-f4f745c9f92a7a4cdd5c25f10a2fb0c5cf9a3650.tar.bz2
aports-f4f745c9f92a7a4cdd5c25f10a2fb0c5cf9a3650.tar.xz
testing/php7-memcached: PHP7 Memcached library
Diffstat (limited to 'testing/php7-memcached/APKBUILD')
-rw-r--r--testing/php7-memcached/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/php7-memcached/APKBUILD b/testing/php7-memcached/APKBUILD
new file mode 100644
index 0000000000..642f1cd296
--- /dev/null
+++ b/testing/php7-memcached/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-memcached
+_pkgreal=memcached
+_pkgrepo=php-memcached
+_pkgbranch=php7
+pkgver=3.0.0b1
+pkgrel=0
+pkgdesc="PHP extension for interfacing with memcached via libmemcached library"
+url="https://github.com/$_pkgrepo-dev/$_pkgrepo/tree/$_pkgbranch"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf zlib-dev"
+makedepends="$pecldepends libmemcached-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgrepo-dev/$_pkgrepo/archive/$_pkgbranch.tar.gz"
+
+builddir="$srcdir"/$_pkgrepo-$_pkgbranch
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure \
+ --prefix=/usr \
+ --disable-memcached-sasl \
+ --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="180153447695701d312316a466658918 php7-memcached-3.0.0b1.tar.gz"
+sha256sums="22b00c65301bb4bfc7b44280f2c6a34f4f01e40bf8b74bf8397705dfac00acd9 php7-memcached-3.0.0b1.tar.gz"
+sha512sums="b670ee0c6232ed0533c07a0a48ac60f51377d15897481b24117e3aea68171460cbd791a2ed3e2b1b11e654ea5bfb0f5eb98c92ef042c72f44e6628056ad90b19 php7-memcached-3.0.0b1.tar.gz"