aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-mustache
diff options
context:
space:
mode:
authorRenoir Boulanger <hello@renoirboulanger.com>2017-06-13 20:53:05 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 07:48:34 +0000
commit2dd190173acb3b33a0ddbd23ec323e7581746f2d (patch)
treecb20dfdce40dd345ce7a1d387a86f0ea92ba3c47 /testing/php7-mustache
parent893d39a018327fe132ad3bbe984d63a7f80b73a3 (diff)
downloadaports-2dd190173acb3b33a0ddbd23ec323e7581746f2d.tar.bz2
aports-2dd190173acb3b33a0ddbd23ec323e7581746f2d.tar.xz
testing/php7-mustache: new aport
https://github.com/jbboehr/php-mustache Mustache PHP Extension [TT: configure host, add check()]
Diffstat (limited to 'testing/php7-mustache')
-rw-r--r--testing/php7-mustache/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/php7-mustache/APKBUILD b/testing/php7-mustache/APKBUILD
new file mode 100644
index 0000000000..b34a793e93
--- /dev/null
+++ b/testing/php7-mustache/APKBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
+
+pkgname=php7-mustache
+_phpext=mustache
+pkgver=0.7.3
+pkgrel=0
+pkgdesc="PHP 7 PECL extension: C++ implementation of Mustache"
+giturl="https://github.com/jbboehr/php-mustache.git"
+url="https://github.com/jbboehr/php-mustache"
+arch=all
+license=MIT
+depends=libmustache
+makedepends="php7-dev autoconf"
+# Look at commit ref for spec/ folder at https://github.com/jbboehr/mustache-spec
+_mustachespec_gitrev=72233f3ffda9e33915fd3022d0a9ebbcce265acd
+_pkg_filename=php-mustache-$pkgver
+source="php-mustache-$pkgver.tar.gz::https://github.com/jbboehr/php-mustache/archive/v$pkgver.tar.gz
+ mustache-spec-$_mustachespec_gitrev.tar.gz::https://github.com/jbboehr/mustache-spec/archive/$_mustachespec_gitrev.tar.gz"
+builddir="$srcdir/$_pkg_filename/"
+
+prepare() {
+ rm -rf "$builddir"/spec
+ ln -s "$srcdir"/mustache-spec-$_mustachespec_gitrev "$builddir"/spec
+ cd "$builddir"
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-php-config=php-config7 \
+ --enable-mustache
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test < /dev/null
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_phpext.so" > "$pkgdir"/etc/php7/conf.d/70_$_phpext.ini
+}
+
+sha512sums="672d8e64aea0c843a85e8ec1501d2453f8cff5237ce160185ecc3fc421e31000f806aec8d4055b558d32d4a1017b80ca05868b36ebf81892a2b7f910a09da235 php-mustache-0.7.3.tar.gz
+d63ca7c3016190e101b2db153a33e4e523e0199e3fb3778733d791e4853bab20925046d0cb34bbde0985a4b6b78b1ec6003db1e2384693352d03f7d67799ed10 mustache-spec-72233f3ffda9e33915fd3022d0a9ebbcce265acd.tar.gz"