aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-oauth
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-07 07:56:41 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:42:41 +0000
commitdff56cf8807e9e4bbf7694f22838fbd7ff9bb786 (patch)
treea6f1ec8de5d661015ad3101bc36425288d51aeb2 /testing/php7-oauth
parenta8d23e79ee1a73ae963fed670eb4edc32318f8cd (diff)
downloadaports-dff56cf8807e9e4bbf7694f22838fbd7ff9bb786.tar.bz2
aports-dff56cf8807e9e4bbf7694f22838fbd7ff9bb786.tar.xz
testing/php7-oauth: PHP7 OAuth package
Diffstat (limited to 'testing/php7-oauth')
-rw-r--r--testing/php7-oauth/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-oauth/APKBUILD b/testing/php7-oauth/APKBUILD
new file mode 100644
index 0000000000..87e72d634e
--- /dev/null
+++ b/testing/php7-oauth/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-oauth
+_pkgreal=oauth
+pkgver=2.0.1
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="OAuth is an authorization protocol built on top of HTTP."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf pcre-dev"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
+}
+
+md5sums="d8fb8bc415f1ccef01c728d45f8bd4fa oauth-2.0.1.tgz"
+sha256sums="fcd6956a64c437af6704eaf0459776513f05cf878ef32cbf5ee09f1a6142fd9a oauth-2.0.1.tgz"
+sha512sums="904eb945303fdbe4c36fa7ba80ebe56796eb2d3b506140827ddcb50fce94b3fab98ed67e7b93b6b56acb20251e79dd8de6218bbfe064ae4cdbe78d9720ac93f7 oauth-2.0.1.tgz"