aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-redis
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-03-19 10:18:29 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-06 05:34:38 +0000
commit1fe480d1948bfdf2cd405da8fa1f4ffcf342e287 (patch)
treefb27a2210bb00b9bcdec5953b43bd81a7f71332e /testing/php7-redis
parent11b0ec9392537e597b334097297e07eadedbefd9 (diff)
downloadaports-1fe480d1948bfdf2cd405da8fa1f4ffcf342e287.tar.bz2
aports-1fe480d1948bfdf2cd405da8fa1f4ffcf342e287.tar.xz
testing/php7-redis: PHP7 Redis package
Diffstat (limited to 'testing/php7-redis')
-rw-r--r--testing/php7-redis/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/php7-redis/APKBUILD b/testing/php7-redis/APKBUILD
new file mode 100644
index 0000000000..bfb9901d6e
--- /dev/null
+++ b/testing/php7-redis/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-redis
+_pkgreal=redis
+_pkgrepo=phpredis
+_pkgbranch=php7
+pkgver=2.2.8
+pkgrel=0
+pkgdesc="PHP extension for interfacing with Redis (Dev PHP7)"
+url="https://github.com/$_pkgrepo/$_pkgrepo/tree/$_pkgbranch"
+arch="x86_64 armhf"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="$_pkgrepo-$pkgver.tar.gz::https://github.com/$_pkgrepo/$_pkgrepo/archive/$_pkgbranch.tar.gz"
+
+builddir="$srcdir"/$_pkgrepo-$_pkgbranch
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="6c47b6722d2970267e0f6b4f85cff675 phpredis-2.2.8.tar.gz"
+sha256sums="9304805acbe5d7c9b4378279b27297bf1bddb96a66541c5e4b2fe22ffa2297f0 phpredis-2.2.8.tar.gz"
+sha512sums="3c943d21d305dfa8db6c56760031ac2e0de26a6282de0ddbbd61926cb336c76160d3533087fa0198c45b3fb72fb2e9eae5d95189cb2dcace52861ce1a596b10f phpredis-2.2.8.tar.gz"