aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-uuid
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-21 17:19:06 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-03-29 23:54:43 +0300
commit92d43736bff81f804ac1d9bf6e655a69124bd6d3 (patch)
treed4daf222cee42586f47dcbdc9eba6e354c07ed93 /testing/php7-uuid
parent2529c22641389ccd369a3f7174f1d0e67d003751 (diff)
downloadaports-92d43736bff81f804ac1d9bf6e655a69124bd6d3.tar.bz2
aports-92d43736bff81f804ac1d9bf6e655a69124bd6d3.tar.xz
testing/php7-uuid: modernize
Diffstat (limited to 'testing/php7-uuid')
-rw-r--r--testing/php7-uuid/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/testing/php7-uuid/APKBUILD b/testing/php7-uuid/APKBUILD
index 052f08f68d..df9a5ebf88 100644
--- a/testing/php7-uuid/APKBUILD
+++ b/testing/php7-uuid/APKBUILD
@@ -4,34 +4,34 @@ pkgname=php7-uuid
_pkgreal=uuid
pkgver=1.0.4
_pkgver=${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="A wrapper around libuuid from the ext2utils project."
url="http://pecl.php.net/package/$_pkgreal"
arch="all"
license="PHP"
-depends=
+depends=""
pecldepends="php7-dev autoconf util-linux-dev"
makedepends="$pecldepends"
-install=""
-subpackages=""
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
-
-builddir="$srcdir"/$_pkgreal-$_pkgver
+builddir="$srcdir/$_pkgreal-$_pkgver"
build() {
cd "$builddir"
- phpize7 || return 1
- ./configure --prefix=/usr --with-php-config=php-config7 || return 1
- make || return 1
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir"/ install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
}
-md5sums="1695511daf585fcaf7816a401a6216f6 uuid-1.0.4.tgz"
-sha256sums="63079b6a62a9d43691ecbcd4eb52e5e5fe17b5a3d0f8e46e3c17ff265c06a11f uuid-1.0.4.tgz"
sha512sums="989d993f8158a13026b8e5c02f4aa50489b1a946d12da81dd1fff6091839a45b180562f74c8af368a498c495477374ec9e1d536e7de0178c1f288e3abe360164 uuid-1.0.4.tgz"