aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-uuid
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-07 08:22:50 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:45:17 +0000
commite8fa3fbaa5cbbaa8e4c60c2ef95d264d70b9ce48 (patch)
tree4c5a442f71664893810e1d4d1d848f5de83fd3f3 /testing/php7-uuid
parentbc1f462ab9cc48b81127db0e246063040d740c8b (diff)
downloadaports-e8fa3fbaa5cbbaa8e4c60c2ef95d264d70b9ce48.tar.bz2
aports-e8fa3fbaa5cbbaa8e4c60c2ef95d264d70b9ce48.tar.xz
testing/php7-uuid: PHP7 UUID package
Diffstat (limited to 'testing/php7-uuid')
-rw-r--r--testing/php7-uuid/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-uuid/APKBUILD b/testing/php7-uuid/APKBUILD
new file mode 100644
index 0000000000..44d9b7b7f9
--- /dev/null
+++ b/testing/php7-uuid/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-uuid
+_pkgreal=uuid
+pkgver=1.0.4
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="A wrapper around libuuid from the ext2utils project."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf util-linux-dev"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
+}
+
+md5sums="1695511daf585fcaf7816a401a6216f6 uuid-1.0.4.tgz"
+sha256sums="63079b6a62a9d43691ecbcd4eb52e5e5fe17b5a3d0f8e46e3c17ff265c06a11f uuid-1.0.4.tgz"
+sha512sums="989d993f8158a13026b8e5c02f4aa50489b1a946d12da81dd1fff6091839a45b180562f74c8af368a498c495477374ec9e1d536e7de0178c1f288e3abe360164 uuid-1.0.4.tgz"