aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-xdebug
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-03-11 17:33:17 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-03-18 09:32:47 +0000
commitaaa595b864419c14130b221b831841c9bfd4a7cb (patch)
tree439fee5110f83c6971b582ea657fcb7593067b98 /testing/php7-xdebug
parentf8dc297ca3498bcc7b520c889f3e05bb71df24ff (diff)
downloadaports-aaa595b864419c14130b221b831841c9bfd4a7cb.tar.bz2
aports-aaa595b864419c14130b221b831841c9bfd4a7cb.tar.xz
testing/php7-xdebug: PHP7 Xdebug package
Diffstat (limited to 'testing/php7-xdebug')
-rw-r--r--testing/php7-xdebug/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-xdebug/APKBUILD b/testing/php7-xdebug/APKBUILD
new file mode 100644
index 0000000000..cb307f99ef
--- /dev/null
+++ b/testing/php7-xdebug/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-xdebug
+_pkgreal=xdebug
+pkgver=2.4.0
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP extension provides functions for function traces and profiling"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "zend_extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="f49fc01332468f8b753fb37115505fb5 xdebug-2.4.0.tgz"
+sha256sums="3c4dcb2709d1653534e7cfaa546307041afd298ac48a3670183a12cfdb5eee05 xdebug-2.4.0.tgz"
+sha512sums="3cc4b5d0cec8048543a9b34a61479303b15fe765d24507a2d24ac42f2f18c625cccc3c44b2e4dacb923f05dd429df8ca3a8909a9def9920d3f44514a31f7cf29 xdebug-2.4.0.tgz"