aboutsummaryrefslogtreecommitdiffstats
path: root/testing/physlock
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-08-14 08:26:31 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-08-14 07:38:43 +0000
commit1bb28507c8c185a1cfe8ce5e7978e964aae2337f (patch)
treeb3dc6402973153f5c0cd6fbd63746902674f0b25 /testing/physlock
parentab1d5f4dd316962e6d798a4ca333b0030a97980b (diff)
downloadaports-1bb28507c8c185a1cfe8ce5e7978e964aae2337f.tar.bz2
aports-1bb28507c8c185a1cfe8ce5e7978e964aae2337f.tar.xz
testing/physlock: new aport
Diffstat (limited to 'testing/physlock')
-rw-r--r--testing/physlock/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/physlock/APKBUILD b/testing/physlock/APKBUILD
new file mode 100644
index 0000000000..efa9d46882
--- /dev/null
+++ b/testing/physlock/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=physlock
+pkgver=0.4.5
+pkgrel=0
+pkgdesc="Lightweight linux console locking tool"
+url="https://github.com/muennich/physlock"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/muennich/physlock/archive/v${pkgver}.tar.gz"
+options="suid"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ make PREFIX="/usr" \
+ -C "$_builddir"
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX="/usr" \
+ -C "$_builddir" install
+}
+
+md5sums="5b39391638375c680599779aeee65569 physlock-0.4.5.tar.gz"
+sha256sums="5ddb42553142c5e2b8744d086bb8f5bf131a29fc58b8886e825b80e6a456961c physlock-0.4.5.tar.gz"
+sha512sums="ab2e71bdc0004d97e3742cf8155602c036dafa22156147cc3cd4050c1665e54d4ca04ee8dc1f763e6369a5d6592524cbc8e10c56870905a1b13385640f4ec476 physlock-0.4.5.tar.gz"