aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pipexec
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-12-02 04:41:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-02 04:41:30 +0000
commit9b450052fb101b6b8776fa0026ae84ab470f8582 (patch)
tree6d25555eb8fc8ecfe9e13300d1715decadaff4b5 /testing/pipexec
parent721383758e90ec21d79710332b8f53d629565fa4 (diff)
downloadaports-9b450052fb101b6b8776fa0026ae84ab470f8582.tar.bz2
aports-9b450052fb101b6b8776fa0026ae84ab470f8582.tar.xz
testing/pipexec: getting rid of bash
Diffstat (limited to 'testing/pipexec')
-rw-r--r--testing/pipexec/APKBUILD4
-rw-r--r--testing/pipexec/dont-require-bash.patch23
2 files changed, 25 insertions, 2 deletions
diff --git a/testing/pipexec/APKBUILD b/testing/pipexec/APKBUILD
index 234ef81bfe..2da7b8293e 100644
--- a/testing/pipexec/APKBUILD
+++ b/testing/pipexec/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pipexec
pkgver=2.5.5
-pkgrel=0
+pkgrel=1
pkgdesc="Handling pipe of commands like a single command"
url="https://github.com/flonatel/pipexec"
arch="all"
@@ -44,4 +44,4 @@ package() {
}
sha512sums="5f33f42ffec1e16090491895fb7403de6c0fcdf99e0fef7a49db19684b261a355ab0e0364891d1dfdaf47ff32671f2725d5e236df29e3f3feb5484cd8ffca0ca pipexec-2.5.5.tar.xz
-9838e8c45f6ded0e3207be4f225e751cec892ff110e8d18daaae514ea88b0f7a96381b31d425c1178c78f87ee86da4ddf18483fccd5308b9d7daa85c287df3ea dont-require-bash.patch"
+b0959c98aea9f3b6580101cfaf65480c3460eebadf377cbdf70f33ff431b731e5e3128efe848dd9678bcfcfd8f8f01dedee520614cd754a617c09b1a2e82c705 dont-require-bash.patch"
diff --git a/testing/pipexec/dont-require-bash.patch b/testing/pipexec/dont-require-bash.patch
new file mode 100644
index 0000000000..035d49cb95
--- /dev/null
+++ b/testing/pipexec/dont-require-bash.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile.in b/Makefile.in
+index 1a10a34..faa57ee 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1354,7 +1354,7 @@ uninstall-am: uninstall-binPROGRAMS uninstall-libLTLIBRARIES
+
+ @USE_VERSION_FILE_FALSE@.FORCE: src/app_version.c
+ @USE_VERSION_FILE_FALSE@src/app_version.c:
+-@USE_VERSION_FILE_FALSE@ bash $(top_srcdir)/build/version-gen.sh ${top_srcdir}
++@USE_VERSION_FILE_FALSE@ sh $(top_srcdir)/build/version-gen.sh ${top_srcdir}
+
+ # Local Variables:
+ # mode: makefile
+diff --git a/version.sh b/version.sh
+index 9f5ae2a..1150c91 100755
+--- a/version.sh
++++ b/version.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ set -e
+
+ TOPSRCDIR=""