aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pony-stable
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-01 01:44:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-01 01:48:33 +0200
commitcbcce0efb040d2c182f9cf1c054e70bea3124dc2 (patch)
tree247fc02539bf5b154d596a13cea0f714e6f8c0b5 /testing/pony-stable
parent6cd0c89e3970f1f86b2ebaf6e31d9f055cdfd115 (diff)
downloadaports-cbcce0efb040d2c182f9cf1c054e70bea3124dc2.tar.bz2
aports-cbcce0efb040d2c182f9cf1c054e70bea3124dc2.tar.xz
testing/pony-stable: new aport
https://github.com/ponylang/pony-stable A simple dependency manager for the Pony language
Diffstat (limited to 'testing/pony-stable')
-rw-r--r--testing/pony-stable/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/pony-stable/APKBUILD b/testing/pony-stable/APKBUILD
new file mode 100644
index 0000000000..24c20a60a0
--- /dev/null
+++ b/testing/pony-stable/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pony-stable
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="A simple dependency manager for the Pony language"
+url="https://github.com/ponylang/pony-stable"
+arch="x86_64" # limited by ponyc
+license="BSD-2-Clause"
+options="!check" # no tests provided
+makedepends="ponyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -m 755 -D build/release/stable "$pkgdir"/usr/bin/stable
+}
+
+sha512sums="7d1638356c846ef1367774d2decf80192fefce73d4bfdd8202fbaf2a87875362dbcb65a5fe254dda239edd1f89c856634380d9c19a640d9b6eb7e19d063d102b pony-stable-0.1.1.tar.gz"