aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:52:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:56:37 +0200
commitd4c1b9ad854296a4cf75ef68fbe7f8be0916a024 (patch)
tree5408a98b5d380322408968ee473910e795536c56 /testing/ponyc
parentb309c535d8516992b6cace4037c992441da8d670 (diff)
downloadaports-d4c1b9ad854296a4cf75ef68fbe7f8be0916a024.tar.bz2
aports-d4c1b9ad854296a4cf75ef68fbe7f8be0916a024.tar.xz
testing/ponyc: don't pass -march and -mtune to gcc
Diffstat (limited to 'testing/ponyc')
-rw-r--r--testing/ponyc/APKBUILD6
-rw-r--r--testing/ponyc/makefile-remove-march-mtune.patch (renamed from testing/ponyc/makefile-no-mtune.patch)25
2 files changed, 17 insertions, 14 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 04fd912dca..5c0722060c 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ponyc
pkgver=0.21.3
-pkgrel=0
+pkgrel=1
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
url="https://www.ponylang.org"
arch="x86_64" # TODO: enable aarch64, armhf
@@ -13,7 +13,7 @@ checkdepends="libressl-dev pcre2-dev"
makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz
- makefile-no-mtune.patch
+ makefile-remove-march-mtune.patch
fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -79,5 +79,5 @@ dev() {
}
sha512sums="f89389142d77e93038c77d3fbe9e64c13ce76b9737430969fcdf2916023d0b7195f4d551895eab999798594352b40848be8dcc63af6927e8cc62b7c7000be65d ponyc-0.21.3.tar.gz
-2bb535b0dad3ea9aab02192c131980e5363db348bdc7f993a8e52d08fb5b08223d93c0713a9c1d420844545b5528b80403b9fdba3e0c34dd59f13366db9088c7 makefile-no-mtune.patch
+2e54e98250d16700c833f746afb63fee49349b9245bec22e33e4ad3c81a94063c80e3bf6ce16bd3c97299a36d0f48236d9afd65767eff10825f46acd6b8f224a makefile-remove-march-mtune.patch
46c0125b60cd1db89d7ae958602b087acb2ae1fd8298cd9141828999693a9e39b60d2dac338853406081fc1c138e506243357618197ffd118fe4ac9737bd1565 fix-tests.patch"
diff --git a/testing/ponyc/makefile-no-mtune.patch b/testing/ponyc/makefile-remove-march-mtune.patch
index 4c6c2b6303..dfdbfa2959 100644
--- a/testing/ponyc/makefile-no-mtune.patch
+++ b/testing/ponyc/makefile-remove-march-mtune.patch
@@ -1,22 +1,25 @@
+Don't hassle with -march and -mtune, use gcc defaults.
+
--- a/Makefile
+++ b/Makefile
-@@ -40,7 +40,6 @@
- # Default settings (silent release build).
- config ?= release
- arch ?= native
--tune ?= generic
- bits ?= $(shell getconf LONG_BIT)
-
- ifndef verbose
-@@ -90,9 +89,9 @@
+@@ -90,9 +90,9 @@
destdir ?= $(prefix)/lib/pony/$(tag)
LIB_EXT ?= a
-BUILD_FLAGS = -march=$(arch) -mtune=$(tune) -Werror -Wconversion \
-+BUILD_FLAGS = -march=$(arch) -Werror -Wconversion \
++BUILD_FLAGS = -Werror -Wconversion \
-Wno-sign-conversion -Wextra -Wall
-LINKER_FLAGS = -march=$(arch) -mtune=$(tune)
-+LINKER_FLAGS = -march=$(arch)
++LINKER_FLAGS =
AR_FLAGS ?= rcs
ALL_CFLAGS = -std=gnu11 -fexceptions \
-DPONY_VERSION=\"$(tag)\" -DLLVM_VERSION=\"$(llvm_version)\" \
+@@ -102,7 +102,7 @@
+ -DPONY_VERSION_STR=\"$(version_str)\" \
+ -D_FILE_OFFSET_BITS=64
+ ALL_CXXFLAGS = -std=gnu++11 -fno-rtti
+-LL_FLAGS = -mcpu=$(arch)
++LL_FLAGS =
+
+ # Determine pointer size in bits.
+ BITS := $(bits)