aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pptpclient
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-02 12:55:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-02 12:55:50 +0000
commit07cf6b14f3e2e3e143b8f6c6c5bb5d06d737d6e0 (patch)
treeeaf9bf7825238974032ffeda3ede44567048eb6b /testing/pptpclient
parentc7b122ff4ccd068e30b2855a8aca5e6335b0c974 (diff)
downloadaports-07cf6b14f3e2e3e143b8f6c6c5bb5d06d737d6e0.tar.bz2
aports-07cf6b14f3e2e3e143b8f6c6c5bb5d06d737d6e0.tar.xz
testing/pptpclient: claim maintainership and cleanup
Diffstat (limited to 'testing/pptpclient')
-rw-r--r--testing/pptpclient/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/testing/pptpclient/APKBUILD b/testing/pptpclient/APKBUILD
index cfa0fe2d09..6be631a2a1 100644
--- a/testing/pptpclient/APKBUILD
+++ b/testing/pptpclient/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Mikhail Ivko <ivko.mv@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pptpclient
pkgver=1.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
url="http://pptpclient.sourceforge.net/"
arch="all"
@@ -10,20 +10,18 @@ license="GPL"
depends="ppp-daemon iproute2"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-options="!check"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/pptp-$pkgver.tar.gz
pptpclient-musl.patch"
-prepare() {
+builddir="$srcdir"/pptp-$pkgver
+build() {
cd "$srcdir"/pptp-$pkgver
- patch -p1 -i "$srcdir"/pptpclient-musl.patch || return 1
- sed -i '/CFLAGS/d' Makefile
- sed -i 's|\/bin\/ip|\/sbin\/ip|g' Makefile
+ make IP=/sbin/ip
}
-build() {
- cd "$srcdir"/pptp-$pkgver
- make || return 1
+check() {
+ cd "$builddir"
+ ./pptp --version
}
package() {