aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ptylie
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-09-10 00:49:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-09-10 00:49:49 +0200
commit82812c57a1b6025b14aa1f8f37922f5eb18f1a0f (patch)
tree87d7fad0dec7b1740ce06256c5fbb5e9d0d7f137 /testing/ptylie
parent11c6101a735134da422a8148b0c62a520d98997f (diff)
downloadaports-82812c57a1b6025b14aa1f8f37922f5eb18f1a0f.tar.bz2
aports-82812c57a1b6025b14aa1f8f37922f5eb18f1a0f.tar.xz
testing/ptylie: new aport
https://github.com/p-gen/ptylie Record a terminal session with automatic keyboard entry
Diffstat (limited to 'testing/ptylie')
-rw-r--r--testing/ptylie/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/ptylie/APKBUILD b/testing/ptylie/APKBUILD
new file mode 100644
index 0000000000..878cd14d64
--- /dev/null
+++ b/testing/ptylie/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ptylie
+pkgver=0.2
+pkgrel=0
+pkgdesc="Record a terminal session with automatic keyboard entry"
+url="https://github.com/p-gen/ptylie"
+arch="all"
+license="GPL-2.0"
+options="suid !check" # no tests provided
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/p-gen/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="37945007d9eabcdf02aa67150567e2a39c8fa56d0948aecc245b6135c7f5687f0e92a3cc8562771400f6198d5b1ee91ee9e5ea5a298ae5822c00c0c2d1203728 ptylie-0.2.tar.gz"