aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-almost
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 15:02:26 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:41 +0000
commitf8436c4d4a64255bd04f9ac2400068ec76e1fcce (patch)
tree2d515a586bcbbb56d638f826b1e1af025fe21d27 /testing/py-almost
parenta8241be18dce562043b8630515a2ce1952acdd48 (diff)
downloadaports-f8436c4d4a64255bd04f9ac2400068ec76e1fcce.tar.bz2
aports-f8436c4d4a64255bd04f9ac2400068ec76e1fcce.tar.xz
testing/py-almost: new aport
A Python helper to compare two numbers generously https://pypi.python.org/pypi/almost
Diffstat (limited to 'testing/py-almost')
-rw-r--r--testing/py-almost/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-almost/APKBUILD b/testing/py-almost/APKBUILD
new file mode 100644
index 0000000000..5094933f00
--- /dev/null
+++ b/testing/py-almost/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-almost
+_pkgname=almost
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="A Python helper to compare two numbers generously"
+url="https://pypi.python.org/pypi/almost"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2b0c0f576341622d7dd18d32a6c1d402 almost-0.1.5.tar.gz"
+sha256sums="e192af9fb078b0276d001bfb52958511aef703a716e5b63678535a59ad560f5b almost-0.1.5.tar.gz"
+sha512sums="0ae4ef19de15abe54380b0eb157574528294cf5cf4bb8f0cedbd7d19307fe52acf14f5da612bf8e83bb1bd6fa98c070988cbb0bf79d52d50dcba725104a15214 almost-0.1.5.tar.gz"