aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-amqp/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:50:35 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:50:35 +0000
commitc567477c0eb21d0f56734dbda0c7a4937e362764 (patch)
tree133c2f235f9dcb99c4d388bc0b9e6b69e53c2ff9 /testing/py-amqp/APKBUILD
parentc2ae382502b0a92e7a6ea199e9f9ac1ddb50afa9 (diff)
downloadaports-c567477c0eb21d0f56734dbda0c7a4937e362764.tar.bz2
aports-c567477c0eb21d0f56734dbda0c7a4937e362764.tar.xz
testing/py-amqp: new aport
Diffstat (limited to 'testing/py-amqp/APKBUILD')
-rw-r--r--testing/py-amqp/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-amqp/APKBUILD b/testing/py-amqp/APKBUILD
new file mode 100644
index 0000000000..5b8674147e
--- /dev/null
+++ b/testing/py-amqp/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-amqp
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="an AMQP implementation"
+url="https://pypi.python.org/pypi/amqp/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-amqp:py2 py3-amqp:py3"
+source="https://files.pythonhosted.org/packages/source/a/amqp/amqp-$pkgver.tar.gz"
+builddir="$srcdir/amqp-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="dcb6297917d4528cfe3ebc446e97be6fed3c100ea77c68923c923cac466fa2d85ed8afaf19582b281ee6e05d699e8ed3fd6cdcbb0cb4de0451becaf16711af29 amqp-2.2.1.tar.gz"