aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-augeas
diff options
context:
space:
mode:
authorNathan Rennie-Waldock <nathan.renniewaldock@gmail.com>2017-11-08 16:37:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-15 08:21:47 +0000
commit784797136857eb21ecc7db14876724c9e8cd7e04 (patch)
tree72e3bed181525e0330b369acb901fcd936d88931 /testing/py-augeas
parent7d4e274927010e16c0d8a14d0502a1faea25ed5a (diff)
downloadaports-784797136857eb21ecc7db14876724c9e8cd7e04.tar.bz2
aports-784797136857eb21ecc7db14876724c9e8cd7e04.tar.xz
testing/py-augeas: depend on augeas-libs and add check()
Diffstat (limited to 'testing/py-augeas')
-rw-r--r--testing/py-augeas/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/py-augeas/APKBUILD b/testing/py-augeas/APKBUILD
index 864abb8a20..fcacfd674c 100644
--- a/testing/py-augeas/APKBUILD
+++ b/testing/py-augeas/APKBUILD
@@ -8,6 +8,7 @@ pkgdesc="Pure python bindings for augeas"
url="https://pypi.python.org/pypi/python-augeas"
arch="noarch"
license="GPL2.1"
+depends="augeas-libs"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -20,6 +21,12 @@ build() {
python3 setup.py build || return 1
}
+check() {
+ cd "$builddir"/test
+ python2 test_augeas.py
+ python3 test_augeas.py
+}
+
package() {
mkdir -p "$pkgdir"
}