aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-augeas
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:47:39 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:47:39 +0000
commitabc9a99d3e2a2813806cb88adf91e10dac30cc91 (patch)
tree4754c9bf7498cffaf15c63d459e53ce25ef54020 /testing/py-augeas
parent6928abc43e245aae98a620afa35a1c76c7e55417 (diff)
downloadaports-abc9a99d3e2a2813806cb88adf91e10dac30cc91.tar.bz2
aports-abc9a99d3e2a2813806cb88adf91e10dac30cc91.tar.xz
testing/py-augeas: new aport
Diffstat (limited to 'testing/py-augeas')
-rw-r--r--testing/py-augeas/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/py-augeas/APKBUILD b/testing/py-augeas/APKBUILD
new file mode 100644
index 0000000000..6e5a80b51e
--- /dev/null
+++ b/testing/py-augeas/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-augeas
+_pkgname=python-augeas
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="Pure python bindings for augeas"
+url="https://pypi.python.org/pypi/python-augeas"
+arch="noarch"
+license="GPL2.1"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+md5sums="2d5a903467410b8d60abca5fa54bae2d python-augeas-0.5.0.tar.gz"
+sha256sums="67d59d66cdba8d624e0389b87b2a83a176f21f16a87553b50f5703b23f29bac2 python-augeas-0.5.0.tar.gz"
+sha512sums="d93d9e21c720084ee3c1841a2172dd1a4cfb41e668de0f557bd214efd65e685a1e5fc713a7d34e0fed727fe908bb1e8a09a1c10587bc27f3708cbcdee575cc51 python-augeas-0.5.0.tar.gz"