aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-beautifulsoup4
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 16:53:34 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 16:53:34 +0000
commita3c940d9ec921598e53b8443fa9dead85dfc8a68 (patch)
tree74d27023d0c2ab52311a9c12a4d3d6f2d0b6f0d9 /testing/py-beautifulsoup4
parent4dd7bc2bd7c2e69e7c6dde1e02b580cc48f0054b (diff)
downloadaports-a3c940d9ec921598e53b8443fa9dead85dfc8a68.tar.bz2
aports-a3c940d9ec921598e53b8443fa9dead85dfc8a68.tar.xz
Revert "testing/py-beautifulsoup4: fixes"
Diffstat (limited to 'testing/py-beautifulsoup4')
-rw-r--r--testing/py-beautifulsoup4/APKBUILD52
-rw-r--r--testing/py-beautifulsoup4/unattended-tests.patch16
2 files changed, 21 insertions, 47 deletions
diff --git a/testing/py-beautifulsoup4/APKBUILD b/testing/py-beautifulsoup4/APKBUILD
index cba1869918..26dce245b0 100644
--- a/testing/py-beautifulsoup4/APKBUILD
+++ b/testing/py-beautifulsoup4/APKBUILD
@@ -1,57 +1,47 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-beautifulsoup4
_pkgname=beautifulsoup4
pkgver=4.6.0
-pkgrel=1
+pkgrel=0
pkgdesc="A Python HTML/XML parser"
url="http://www.crummy.com/software/BeautifulSoup/index.html"
arch="noarch"
license="MIT"
-makedepends="py-setuptools py3-setuptools py-sphinx"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3 $pkgname-doc" # do not change the order
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- unattended-tests.patch"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+build() {
cd "$builddir"
- msg "subpkdir is $subpkgdir"
- $python setup.py build -b $python install --prefix=/usr --root="$subpkgdir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
}
_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
_py python2
}
_py3() {
- cd "$builddir"
- rm -rf bs4
- mv py3k/bs4 bs4
+ depends="${depends//py-/py3-}"
_py python3
}
-package() {
- cd "$builddir"
- install -d "$pkgdir"/usr/share/doc/$pkgname "$pkgdir"/usr/share/man/man1 "$pkgdir"/usr/share/html/$pkgname
- install -t "$pkgdir"/usr/share/doc/$pkgname AUTHORS.txt README.txt TODO.txt
- cd doc
- PYTHONPATH="$builddir/src" make html man
- install -t "$pkgdir"/usr/share/man/man1 build/man/*
- mv build/html/* "$pkgdir"/usr/share/html/$pkgname
-}
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
-check() {
cd "$builddir"
- python2 setup.py check
- python3 setup.py check
- ./test-all-versions
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578 beautifulsoup4-4.6.0.tar.gz
-5651c62b4a989df212c34e54ce84e61367fc4e992df3d50965fd7ed9589683d5b201db6ea60c2c6e90d9fb9c3bac2cb8553092bd571259744d82e0ba0d28f7b2 unattended-tests.patch"
+sha512sums="1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578 beautifulsoup4-4.6.0.tar.gz"
diff --git a/testing/py-beautifulsoup4/unattended-tests.patch b/testing/py-beautifulsoup4/unattended-tests.patch
deleted file mode 100644
index 623d070085..0000000000
--- a/testing/py-beautifulsoup4/unattended-tests.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/convert-py3k.orig
-+++ b/convert-py3k
-@@ -7,10 +7,10 @@
- echo "About to destroy and rebuild the py3k/bs4 directory."
- echo "If you've got stuff in there, Ctrl-C out of this script or answer 'n'."
- mkdir -p py3k
--rm -rfI py3k/bs4
-+rm -rf py3k/bs4
- cp -r bs4/ py3k/
- 2to3 -w py3k
- echo ""
- echo "OK, conversion is done."
- echo "Now running the unit tests."
--(cd py3k && python3 -m unittest discover -s bs4)
-\ No newline at end of file
-+(cd py3k && python3 -m unittest discover -s bs4)