aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-beautifulsoup4
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-26 17:03:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-26 17:05:21 +0200
commitec868b7d7a9e0b2aa4c90bdd6663920a01e531d5 (patch)
treee838186b28c148362317170d7bd20e5b1710d698 /testing/py-beautifulsoup4
parentcfb9a680e6999fd53d13b68dfa446ab30f5f9e97 (diff)
downloadaports-ec868b7d7a9e0b2aa4c90bdd6663920a01e531d5.tar.bz2
aports-ec868b7d7a9e0b2aa4c90bdd6663920a01e531d5.tar.xz
testing/py-beautifulsoup4: improve abuild
Diffstat (limited to 'testing/py-beautifulsoup4')
-rw-r--r--testing/py-beautifulsoup4/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/py-beautifulsoup4/APKBUILD b/testing/py-beautifulsoup4/APKBUILD
index 809d9678f3..e05726c35a 100644
--- a/testing/py-beautifulsoup4/APKBUILD
+++ b/testing/py-beautifulsoup4/APKBUILD
@@ -11,7 +11,7 @@ license="MIT"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
default_prepare
@@ -44,19 +44,17 @@ package() {
_py2() {
replaces="$pkgname"
- depends="${depends//py-/py2-}"
_py python2
}
_py3() {
- depends="${depends//py-/py3-}"
_py python3
}
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
+ depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir-$python"