aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-pgsql
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 13:20:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commit60ff7f4d4b5b0fee083d4adaa217860ea913d3a5 (patch)
tree66ca6414e952e354b443a39fa30cb515a9cdeb18 /testing/py-bottle-pgsql
parentce5a440534ddecedc60d901e0215d19603840eb9 (diff)
downloadaports-60ff7f4d4b5b0fee083d4adaa217860ea913d3a5.tar.bz2
aports-60ff7f4d4b5b0fee083d4adaa217860ea913d3a5.tar.xz
testing/py-bottle-pgsql: new aport
Bottle PgSQL integration plugin https://github.com/raisoblast/bottle-pgsql
Diffstat (limited to 'testing/py-bottle-pgsql')
-rw-r--r--testing/py-bottle-pgsql/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-pgsql/APKBUILD b/testing/py-bottle-pgsql/APKBUILD
new file mode 100644
index 0000000000..1021629506
--- /dev/null
+++ b/testing/py-bottle-pgsql/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-pgsql
+_pkgname=bottle-pgsql
+pkgver=0.1
+pkgrel=0
+pkgdesc="Bottle PgSQL integration plugin"
+url="https://github.com/raisoblast/bottle-pgsql"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1062bbcc2410d6d7947a1435116a0aa9 bottle-pgsql-0.1.tar.gz"
+sha256sums="2b5bb588620e2d277965f7451347df6ec65e913b6fb45e28a528b93d0d9a0091 bottle-pgsql-0.1.tar.gz"
+sha512sums="a14d7cae86d7efa4cb7734886d34b8922fb06cbb47e46ecabf6cc993f9e266e2e072b1c0e6849689e6c11c3f20ce638753f2b6fcb4c2f68a3d5f90f1533292cb bottle-pgsql-0.1.tar.gz"