aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-redis
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-18 19:36:50 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 07:53:25 +0000
commita49778cc6f5bbe44d35325f1d5a0f08c1750a152 (patch)
tree64c54db48a94b2058133d8bbcaf802074de79f56 /testing/py-bottle-redis
parent5098a754fd53ce396ec286adfdaa8e669abd5ec9 (diff)
downloadaports-a49778cc6f5bbe44d35325f1d5a0f08c1750a152.tar.bz2
aports-a49778cc6f5bbe44d35325f1d5a0f08c1750a152.tar.xz
testing/py-bottle-redis: new aport
Redis integration for Bottle. https://github.com/bottlepy/bottle-redis
Diffstat (limited to 'testing/py-bottle-redis')
-rw-r--r--testing/py-bottle-redis/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-redis/APKBUILD b/testing/py-bottle-redis/APKBUILD
new file mode 100644
index 0000000000..24f53c2808
--- /dev/null
+++ b/testing/py-bottle-redis/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-redis
+_pkgname=bottle-redis
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Bottle redis plugin"
+url="https://github.com/bottlepy/bottle-redis"
+arch="noarch"
+license="MIT"
+depends="python py-bottle py-redis"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="884fadac271f10fba90c2886e4682f4b bottle-redis-0.2.1.tar.gz"
+sha256sums="656fc3d42cec1e935d7aa40b314e714b9bfec1fa9044b0f1731bc8fcb6bb16f9 bottle-redis-0.2.1.tar.gz"
+sha512sums="2db020bb786113e32d7f9dcf6fceb80426f7bd154eb3e5403372c7ebb82c55a8df0aad7a5fca6e47b1329eee1c14d1bfb833734951597083717da742a6461b91 bottle-redis-0.2.1.tar.gz"