aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-werkzeug
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 15:06:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commitb80e6524f2445681e5c5a1868bbce1f4eb0fb150 (patch)
tree0d14ae0298a875128cecb15a212c40842e7974f4 /testing/py-bottle-werkzeug
parent9c415dfdf02ac95bff84c15d9d34c536135470ad (diff)
downloadaports-b80e6524f2445681e5c5a1868bbce1f4eb0fb150.tar.bz2
aports-b80e6524f2445681e5c5a1868bbce1f4eb0fb150.tar.xz
testing/py-bottle-werkzeug: new aport
Bottle werkzeug plugin https://pypi.python.org/pypi/bottle-werkzeug
Diffstat (limited to 'testing/py-bottle-werkzeug')
-rw-r--r--testing/py-bottle-werkzeug/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-werkzeug/APKBUILD b/testing/py-bottle-werkzeug/APKBUILD
new file mode 100644
index 0000000000..5346a918c5
--- /dev/null
+++ b/testing/py-bottle-werkzeug/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-werkzeug
+_pkgname=bottle-werkzeug
+pkgver=0.1
+pkgrel=0
+pkgdesc="Bottle werkzeug plugin"
+url="https://pypi.python.org/pypi/bottle-werkzeug"
+arch="noarch"
+license="MIT"
+depends="python py-bottle py-werkzeug"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b8d63aa1d562d66a82d8cb22c768366a bottle-werkzeug-0.1.tar.gz"
+sha256sums="98093936e8d3734b5c4218a87b6137bee645e365f55e1580663090e844a597f2 bottle-werkzeug-0.1.tar.gz"
+sha512sums="7f578a3daec101588c82d0a991bc2a916fa6920a98bddceedde371adef68baa1b6d9195efd87a44418101916068630e6b54f24499afbe32551103601cfe53701 bottle-werkzeug-0.1.tar.gz"