aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-click
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-03-06 06:47:16 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-03-11 14:33:18 +0000
commitdcb5a3721040a03ffce86084c6e4c6c8705d59e8 (patch)
tree6a4337f5e77a85cedc4ce40269cec340096dd800 /testing/py-click
parent0ec431d2a5d0ddf3a2ee1d4f7c4a86ca77e58f3b (diff)
downloadaports-dcb5a3721040a03ffce86084c6e4c6c8705d59e8.tar.bz2
aports-dcb5a3721040a03ffce86084c6e4c6c8705d59e8.tar.xz
testing/py-click: new aport
A simple wrapper around optparse for powerful command line utilities. https://pypi.python.org/pypi/click
Diffstat (limited to 'testing/py-click')
-rw-r--r--testing/py-click/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-click/APKBUILD b/testing/py-click/APKBUILD
new file mode 100644
index 0000000000..af4046cf14
--- /dev/null
+++ b/testing/py-click/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-click
+_pkgname=click
+pkgver=3.3
+pkgrel=0
+pkgdesc="A simple wrapper around optparse for powerful command line utilities."
+url="https://pypi.python.org/pypi/click"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="40edaba4d216915a8326c5b2cb52781d click-3.3.tar.gz"
+sha256sums="f79c8c04d7eb50071bcad67fd23f3c10fab6c72d56857adf848367806845d6e5 click-3.3.tar.gz"
+sha512sums="fe2f85d5f60c26c9dbfff5d689e21e8f728d6f6b092ab93a66339b1cc7ee25d8e2b21235e07f5fbcf16ae1a2fb252537679019c5edc3ca9bf8ced57e39e9a67f click-3.3.tar.gz"