aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-distro
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 04:37:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:34:18 +0200
commit7745e71869dbb885ae5ec51ccf0c996065f74aaf (patch)
tree43c128f1b5d6be8de40209f2b874538af7e6eb5b /testing/py-distro
parent7e1385f849981bd66fd5df3e32f4202ab1057719 (diff)
downloadaports-7745e71869dbb885ae5ec51ccf0c996065f74aaf.tar.bz2
aports-7745e71869dbb885ae5ec51ccf0c996065f74aaf.tar.xz
testing/py-distro: new aport
A much more elaborate, renewed alternative implementation for Python's platform.linux_distribution() https://github.com/nir0s/distro
Diffstat (limited to 'testing/py-distro')
-rw-r--r--testing/py-distro/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py-distro/APKBUILD b/testing/py-distro/APKBUILD
new file mode 100644
index 0000000000..379fda3d77
--- /dev/null
+++ b/testing/py-distro/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-distro
+_pkgname=distro
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="A Linux OS platform information API"
+url="https://github.com/nir0s/distro"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+md5sums="d1726863ed44003b4e52884f888918c4 distro-1.0.1.tar.gz"
+sha256sums="b940995858ec63a29a272ddf7916818bb5cccb9297928fb8230fd37a146b1f26 distro-1.0.1.tar.gz"
+sha512sums="adac287d3b36034f92c1c5d7f66216dbffe923d04fd2556b79531dd8ca6dcab73d4771d3e14f5b2516d9692e2a734f614487ffee88738daa13592222d6892860 distro-1.0.1.tar.gz"