aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-dulwich
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-01-21 06:11:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-01-27 16:54:50 +0200
commit5dafe9ab2f89026e87ac001ddf8f576e194249e3 (patch)
tree1e2c1aaadf453c96dcc18800f86bd495293860b2 /testing/py-dulwich
parent121c190a612ba6fe32e524a77501257a8d1bcebf (diff)
downloadaports-5dafe9ab2f89026e87ac001ddf8f576e194249e3.tar.bz2
aports-5dafe9ab2f89026e87ac001ddf8f576e194249e3.tar.xz
testing/py-dulwich: upgrade to 0.15.0
Diffstat (limited to 'testing/py-dulwich')
-rw-r--r--testing/py-dulwich/APKBUILD45
1 files changed, 30 insertions, 15 deletions
diff --git a/testing/py-dulwich/APKBUILD b/testing/py-dulwich/APKBUILD
index f9e917ec49..73c9c69217 100644
--- a/testing/py-dulwich/APKBUILD
+++ b/testing/py-dulwich/APKBUILD
@@ -2,30 +2,45 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-dulwich
_pkgname=dulwich
-pkgver=0.10.0
+pkgver=0.15.0
pkgrel=0
pkgdesc="A python implementation of the Git file formats and protocols"
-url="http://www.samba.org/~jelmer/dulwich/"
+url="https://www.dulwich.io"
arch="all"
license="GPL2+ or ASL 2.0"
-depends=""
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://www.dulwich.io/releases/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
}
-md5sums="caa3222039ca1359c011c2d5e4f2d85b dulwich-0.10.0.tar.gz"
-sha256sums="518bb4aa3e5ad81982bfe571594af81ab9f78feb4e33bfade6c1553afff69237 dulwich-0.10.0.tar.gz"
-sha512sums="a5aa321e1265ee6c96c763a357d204eda7b9d4d6e90e0b18898342f34b9babf4d43857b9974d6bf442f9ba4da54fed4342c5724772cc9028138e8ec75d2e4896 dulwich-0.10.0.tar.gz"
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+}
+
+md5sums="398734f570f140806fdd7958575d5db0 dulwich-0.15.0.tar.gz"
+sha256sums="6f0a09d93f01caf1ba054b3f751d5cc1f0e6afc5c97fd23d67d7acf92f0d0b16 dulwich-0.15.0.tar.gz"
+sha512sums="a0d6b56281513d16e830f234a9baa285b63098256ced7884b084fcd14210b60f2cd5e80bc18b74a7adcab509d5a9ebbb399746fd074083174b5922315af55cc4 dulwich-0.15.0.tar.gz"