aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-enchant
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2018-08-12 11:56:08 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-31 06:17:04 +0000
commit2ec2cbdf98cf6029c8f2641f4316789aa3b74eb1 (patch)
tree8eb19e7b22a24bb4a452e40ece83fadeaf0ce140 /testing/py-enchant
parentf74a048db50a9404603de6da3e621cc1ccde8cf1 (diff)
downloadaports-2ec2cbdf98cf6029c8f2641f4316789aa3b74eb1.tar.bz2
aports-2ec2cbdf98cf6029c8f2641f4316789aa3b74eb1.tar.xz
testing/py-enchant: modernise and add check function
- use default_prepare - replace 404 URL with github - remove unnecessary "return 1"s - use builddir not _builddir, following main/enchant as example - add check function and necessary dependency
Diffstat (limited to 'testing/py-enchant')
-rw-r--r--testing/py-enchant/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/testing/py-enchant/APKBUILD b/testing/py-enchant/APKBUILD
index c8e3375b36..ba84830944 100644
--- a/testing/py-enchant/APKBUILD
+++ b/testing/py-enchant/APKBUILD
@@ -3,37 +3,32 @@
pkgname=py-enchant
_pkgname=pyenchant
pkgver=1.6.6
-pkgrel=0
+pkgrel=1
pkgdesc="A spellchecking library for Python"
-url="http://pythonhosted.org/pyenchant/"
+url="https://github.com/rfk/pyenchant"
arch="noarch"
license="LGPL-2.0-or-later"
-depends="python2"
+depends="python2 enchant"
depends_dev=""
makedepends="python2-dev py-setuptools enchant-dev"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 -c "import enchant"
}
md5sums="9f5acfd87d04432bf8df5f9710a17358 pyenchant-1.6.6.tar.gz"