aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-blind-except
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 22:31:16 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commit02039076375caf8a8c3318c2bf694cdede2209a4 (patch)
treed26e6db63dae0a51272c67c784f171fe4a4e1bf2 /testing/py-flake8-blind-except
parent50699604f9bb6941cd356f85fe601a3adec25bad (diff)
downloadaports-02039076375caf8a8c3318c2bf694cdede2209a4.tar.bz2
aports-02039076375caf8a8c3318c2bf694cdede2209a4.tar.xz
testing/py-flake8-blind-except: update to py3
Diffstat (limited to 'testing/py-flake8-blind-except')
-rw-r--r--testing/py-flake8-blind-except/APKBUILD29
1 files changed, 8 insertions, 21 deletions
diff --git a/testing/py-flake8-blind-except/APKBUILD b/testing/py-flake8-blind-except/APKBUILD
index dc7e5f65e7..708abdc0e4 100644
--- a/testing/py-flake8-blind-except/APKBUILD
+++ b/testing/py-flake8-blind-except/APKBUILD
@@ -3,37 +3,24 @@
pkgname=py-flake8-blind-except
_pkgname=flake8-blind-except
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Extension for flake8 which checks for blind except: statements"
url="https://github.com/elijahandrews/flake8-blind-except"
arch="noarch"
license="MIT"
-depends="python2 flake8"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="flake8"
+makedepends="python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="a76ae6603b53c230ad81f9dea27c6bbb flake8-blind-except-0.1.0.tar.gz"