aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-isort
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-12 13:16:44 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commita6096619b7f694dc4f7d010175ce3d5f5f834cb8 (patch)
tree0680081a56870abf997dd4bc6f0672658913e57b /testing/py-flake8-isort
parentefdb85ecb65f7976bc51c2e70aff6529dae8dc9f (diff)
downloadaports-a6096619b7f694dc4f7d010175ce3d5f5f834cb8.tar.bz2
aports-a6096619b7f694dc4f7d010175ce3d5f5f834cb8.tar.xz
testing/py-flake8-isort: new aport
flake8 plugin that integrates isort https://github.com/gforcada/flake8-isort
Diffstat (limited to 'testing/py-flake8-isort')
-rw-r--r--testing/py-flake8-isort/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-flake8-isort/APKBUILD b/testing/py-flake8-isort/APKBUILD
new file mode 100644
index 0000000000..62733bf0f4
--- /dev/null
+++ b/testing/py-flake8-isort/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-isort
+_pkgname=flake8-isort
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Extension for flake8 which integrates isort"
+url="https://github.com/gforcada/flake8-isort"
+arch="noarch"
+license="GPL2"
+depends="flake8 py3-isort"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="06d102adf075c2dc4d4b4dd4dd534b91 flake8-isort-2.0.1.tar.gz"
+sha256sums="9b994a95b3b26552fa25a8b94d7b345aea87ddb8c3bf78e7869b73ecc6088de7 flake8-isort-2.0.1.tar.gz"
+sha512sums="c2d8006ea9dce62c2a990ab9769d65f1e040fcf3931c61b50a8dd208d3fa0037758102d46dafce4342126a38716b4ff3e06d7015a65a20a8458543ae8b2627d3 flake8-isort-2.0.1.tar.gz"