aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-snippets
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-01-23 20:25:41 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-03-11 14:33:17 +0000
commitc887451311fc9383759f14f9f13a8bef5f03cbf2 (patch)
treee759e38b812f7539d2db1e7373a2533be640b90e /testing/py-flake8-snippets
parent5ffe86f84524b28ac1a69cadeea6b513fa3fe669 (diff)
downloadaports-c887451311fc9383759f14f9f13a8bef5f03cbf2.tar.bz2
aports-c887451311fc9383759f14f9f13a8bef5f03cbf2.tar.xz
testing/py-flake8-snippets: new aport
A flake8 extension to find any code snippets you don't like https://github.com/bitmazk/flake8-snippets
Diffstat (limited to 'testing/py-flake8-snippets')
-rw-r--r--testing/py-flake8-snippets/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flake8-snippets/APKBUILD b/testing/py-flake8-snippets/APKBUILD
new file mode 100644
index 0000000000..df3540df11
--- /dev/null
+++ b/testing/py-flake8-snippets/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-snippets
+_pkgname=flake8-snippets
+pkgver=0.1
+pkgrel=0
+pkgdesc="Extension for flake8 which lint for code snippets"
+url="https://github.com/bitmazk/flake8-snippets"
+arch="noarch"
+license="MIT"
+depends="python py-flake8"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c1724b6d6442f8c91f92bad33741d687 flake8-snippets-0.1.tar.gz"
+sha256sums="80fc92ea1ffa10b53c13fa8eb79dbe1993439cec777ea2737f9b2908c2c1e9e0 flake8-snippets-0.1.tar.gz"
+sha512sums="5c08f96c2470381c59223e796ed9a76ff5bb2abeb6b85204b1af1ccfa0855b13f3629c3f8d83f931328de50fa6916e6c52b4816a83e65e88deefc815c46ea30a flake8-snippets-0.1.tar.gz"