aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-principal
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 12:36:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:30 +0000
commit91ee6cbc6d3c7c4ae10538b7e1965b214614f15d (patch)
tree9754979dc7da15046913a4f3b5e5f04182020e79 /testing/py-flask-principal
parentf01145c5c866dd429700d66cf14e02de669298ca (diff)
downloadaports-91ee6cbc6d3c7c4ae10538b7e1965b214614f15d.tar.bz2
aports-91ee6cbc6d3c7c4ae10538b7e1965b214614f15d.tar.xz
testing/py-flask-principal: new aport
Flask Identity management https://pypi.python.org/pypi/Flask-Principal
Diffstat (limited to 'testing/py-flask-principal')
-rw-r--r--testing/py-flask-principal/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-principal/APKBUILD b/testing/py-flask-principal/APKBUILD
new file mode 100644
index 0000000000..b4e67f9f8d
--- /dev/null
+++ b/testing/py-flask-principal/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-principal
+_pkgname=Flask-Principal
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Flask Identity management"
+url="https://pypi.python.org/pypi/Flask-Principal"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="462d1345c9ddaddbec33a743e5821e2c Flask-Principal-0.4.0.tar.gz"
+sha256sums="f5d6134b5caebfdbb86f32d56d18ee44b080876a27269560a96ea35f75c99453 Flask-Principal-0.4.0.tar.gz"
+sha512sums="18f8f7766af62f99ccd52e34919e3f161ffb727c227c2714d651fad9bf6df3958289389e9b9cfe22d01a150985d1a631db3222626be1c4b12daea22434e4c85e Flask-Principal-0.4.0.tar.gz"