aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-restful
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-10-30 09:31:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-30 12:46:31 +0000
commitde1097b10e014bc04c825e4c1a641a0f0bb409b1 (patch)
tree30085456af226983621b421abb9a8f32c5a9363f /testing/py-flask-restful
parentde79c0eb178f26320e11ed9126b8bab3a66a1144 (diff)
downloadaports-de1097b10e014bc04c825e4c1a641a0f0bb409b1.tar.bz2
aports-de1097b10e014bc04c825e4c1a641a0f0bb409b1.tar.xz
testing/py-flask-restful: new aport
Simple framework for creating REST APIs http://flask-restful.readthedocs.org/en/latest/
Diffstat (limited to 'testing/py-flask-restful')
-rw-r--r--testing/py-flask-restful/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-restful/APKBUILD b/testing/py-flask-restful/APKBUILD
new file mode 100644
index 0000000000..5ff8d20f39
--- /dev/null
+++ b/testing/py-flask-restful/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-restful
+_pkgname=Flask-RESTful
+pkgver=0.3.4
+pkgrel=0
+pkgdesc="Flask RESTful API extension"
+url="https://pypi.python.org/pypi/Flask-RESTful"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="896aff2720fcd915aacfd5651eab20d1 Flask-RESTful-0.3.4.tar.gz"
+sha256sums="89f3773363fb0dd235d16c806b7ff8fed8268152d45bf1fc618a12a36dfd1b68 Flask-RESTful-0.3.4.tar.gz"
+sha512sums="91bf743f9ff90c83770ba65b5345917406b284d53bbd37736c8e0000372eaa1350422a3abb67d2e67db5aa222f2a36a16c26f7c6b14bea17f0f53fe6a54fefdc Flask-RESTful-0.3.4.tar.gz"