aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-h2
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-28 19:59:35 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-10 11:21:39 +0000
commite2335ad99199f707c1660c768f7078c5fd5db48b (patch)
treef63c489dd5f4410f0254ed95e1ee9047a3914369 /testing/py-h2
parent60455f2cfb96156879624d646ff46e3bbb5f2cee (diff)
downloadaports-e2335ad99199f707c1660c768f7078c5fd5db48b.tar.bz2
aports-e2335ad99199f707c1660c768f7078c5fd5db48b.tar.xz
testing/py-h2: new aport
Diffstat (limited to 'testing/py-h2')
-rw-r--r--testing/py-h2/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py-h2/APKBUILD b/testing/py-h2/APKBUILD
new file mode 100644
index 0000000000..651ca84a23
--- /dev/null
+++ b/testing/py-h2/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-h2
+_pkgname=hyper-h2
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="HTTP/2 State-Machine based protocol implementation"
+url="https://python-hyper.org/h2/"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-hyper/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="33fbc08d28b347ed5be6257ea8ba45b59642951e6c716a27bdae86c1c5ccc388dd9bc5beaa62f6f59326f0fa0c39176bb4c8d7ab1c9ae3e2c056000ac2c3f75a py-h2-3.0.0.tar.gz"