aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-ipaddress
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-10-21 17:32:46 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-10-21 17:32:46 +0200
commit5828343af8495755c73bd7a64b4abebb6d81d33c (patch)
tree702263bd0f1a74eed6ca44d3b0e1f23f408b602c /testing/py-ipaddress
parentf01a4d70913b3d06c12c26e44461114629d078a7 (diff)
downloadaports-5828343af8495755c73bd7a64b4abebb6d81d33c.tar.bz2
aports-5828343af8495755c73bd7a64b4abebb6d81d33c.tar.xz
testing/py-ipaddress: new aport
Diffstat (limited to 'testing/py-ipaddress')
-rw-r--r--testing/py-ipaddress/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-ipaddress/APKBUILD b/testing/py-ipaddress/APKBUILD
new file mode 100644
index 0000000000..390517dffb
--- /dev/null
+++ b/testing/py-ipaddress/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-ipaddress
+pkgver=1.0.14
+pkgrel=0
+pkgdesc="IPv4/IPv6 manipulation library"
+url="https://github.com/phihag/ipaddress"
+arch="noarch"
+license="PSF"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/i/ipaddress/ipaddress-$pkgver.tar.gz"
+
+_builddir="$srcdir"/ipaddress-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e2f2f6593b2b8a7e8abba0fbdf33f046 ipaddress-1.0.14.tar.gz"
+sha256sums="226f4be44c6cb64055e23060848266f51f329813baae28b53dc50e93488b3b3e ipaddress-1.0.14.tar.gz"
+sha512sums="fb33b484ca435f4e8817c735a1084f2fa749abca4643a10be644003fdb73cc9205fc28f484ef96d2db90e8b27d8a238d1d7cf20140f7942e39be12c7524e8d6f ipaddress-1.0.14.tar.gz"