aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-jedi
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-06 13:45:25 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-06 13:45:30 +0000
commit6ea630ea328ea8b57fb1028ca560d25f10457234 (patch)
tree5b7512eeeb3ad4fb1823c763791506ab12f6fe11 /testing/py-jedi
parentad0a79552163422c5bebd1b3216a1d06a0560644 (diff)
downloadaports-6ea630ea328ea8b57fb1028ca560d25f10457234.tar.bz2
aports-6ea630ea328ea8b57fb1028ca560d25f10457234.tar.xz
testing/py-jedi: new aport
Diffstat (limited to 'testing/py-jedi')
-rw-r--r--testing/py-jedi/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/py-jedi/APKBUILD b/testing/py-jedi/APKBUILD
new file mode 100644
index 0000000000..3cc4341867
--- /dev/null
+++ b/testing/py-jedi/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-jedi
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="Awesome autocompletion and static analysis library for python."
+url="https://github.com/davidhalter/jedi"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/davidhalter/${pkgname/py-/}/archive/v$pkgver.tar.gz"
+builddir="$srcdir/${pkgname/py-/}-$pkgver"
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="64ff10cf041a107ca709802b41d9ae27b31fc7fa6cff0efdde4c78d01351efdc1333f1a02e2b8004453574199a4651043e7c3fea7149bfe5e3f0e93c23c38320 py-jedi-0.10.0.tar.gz"