aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-kiwisolver
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-05-21 23:31:25 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-17 14:16:23 +0000
commit63db83036528457bdf82a167945872ac695df357 (patch)
treee529091eefaae4ffed8ff7d12d963adc267e4b03 /testing/py-kiwisolver
parentc94934c962e6dc90befa1bf8b5663d06f407a806 (diff)
downloadaports-63db83036528457bdf82a167945872ac695df357.tar.bz2
aports-63db83036528457bdf82a167945872ac695df357.tar.xz
testing/py-kiwisolver: New aport
An efficient implementation of the Cassowary constraint solving algorithm https://pypi.org/project/kiwisolver/
Diffstat (limited to 'testing/py-kiwisolver')
-rw-r--r--testing/py-kiwisolver/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/py-kiwisolver/APKBUILD b/testing/py-kiwisolver/APKBUILD
new file mode 100644
index 0000000000..61950b8358
--- /dev/null
+++ b/testing/py-kiwisolver/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-kiwisolver
+_pkgname=kiwisolver
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="An efficient implementation of the Cassowary constraint solving algorithm"
+url="https://pypi.org/project/kiwisolver/"
+arch="all"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+
+sha512sums="80ed3d7429a2ed4944aa09766bebac2709a3a0e0a184ff414f04bf3c7ec3034ea7d0f70dff319922b870dedaf13d64fc87eff86a82e720ec93a2510885ad738d kiwisolver-1.0.1.tar.gz"