aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-nbxmpp/APKBUILD
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-07-01 15:55:18 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-20 07:40:23 +0000
commit003afe012df5914910e58d65d6f1a01a216f2a27 (patch)
tree18650e431fb22075c7d6f869d06d0bf38f3c8dbc /testing/py-nbxmpp/APKBUILD
parentc7ab6a049d7c0ae6d40ec22e359850decc487b99 (diff)
downloadaports-003afe012df5914910e58d65d6f1a01a216f2a27.tar.bz2
aports-003afe012df5914910e58d65d6f1a01a216f2a27.tar.xz
testing/py-nbxmpp: New aport
https://dev.gajim.org/gajim/python-nbxmpp/ A non-blocking XMPP implementation for python
Diffstat (limited to 'testing/py-nbxmpp/APKBUILD')
-rw-r--r--testing/py-nbxmpp/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/py-nbxmpp/APKBUILD b/testing/py-nbxmpp/APKBUILD
new file mode 100644
index 0000000000..c9ce776aa8
--- /dev/null
+++ b/testing/py-nbxmpp/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-nbxmpp
+_pkgname="${pkgname#py-}"
+pkgver=0.6.6
+pkgrel=0
+pkgdesc="A non-blocking XMPP implementation for python"
+url="https://dev.gajim.org/gajim/python-nbxmpp/"
+arch="noarch"
+license="GPL-3.0-only"
+makedepends="py-setuptools python2-dev python3-dev"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="069cb2be905ac5abf92bc06a1e61a58c41ae38a288d1d51e80eb9b00e250d2a043ca0009288bf228965adeda5acecbc2288f7c0b9007f07ce93196ea59cee206 nbxmpp-0.6.6.tar.gz"