aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-newt_syrup
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-28 00:54:08 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-28 00:54:08 +0000
commit17fb6d6cc55062bd73ebb08f652cc6100ec8f238 (patch)
treeb4e3190df84904501d677e435895c13ec4d5adb8 /testing/py-newt_syrup
parent7e332cddce5bdba21edb12e15016587451c8d51f (diff)
downloadaports-17fb6d6cc55062bd73ebb08f652cc6100ec8f238.tar.bz2
aports-17fb6d6cc55062bd73ebb08f652cc6100ec8f238.tar.xz
testing/py-newt_syrup: update source
Diffstat (limited to 'testing/py-newt_syrup')
-rw-r--r--testing/py-newt_syrup/APKBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/testing/py-newt_syrup/APKBUILD b/testing/py-newt_syrup/APKBUILD
index 4270c8d0a0..5e8507fccc 100644
--- a/testing/py-newt_syrup/APKBUILD
+++ b/testing/py-newt_syrup/APKBUILD
@@ -13,30 +13,22 @@ depends_dev=""
makedepends="python-dev py-setuptools"
install=""
subpackages=""
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/mcpierce/newt-syrup/archive/RELEASE-0.2.0.tar.gz"
+source="https://mcpierce.fedorapeople.org/sources/newt_syrup-$pkgver.tar.gz"
-_builddir="$srcdir"/${_realname}-RELEASE-$pkgver
+builddir="$srcdir"/${_realname}-RELEASE-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/newt_syrup-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py build || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="7f41378272a8aeea64dbb99e5c4d3ef0 py-newt_syrup-0.2.0.tar.gz"
-sha256sums="5c92b37984186ce16d036c978564810430bc39209acae85010ca2c7dc0143ef9 py-newt_syrup-0.2.0.tar.gz"
-sha512sums="ea1573a35cb097a7ff0ae1326eaedef37fbfe4af8e5b7bf17e17f785ae35823797cde570f366eb8168f81e520ef75d209a15b6c9192fe2e92294d76f312016fa py-newt_syrup-0.2.0.tar.gz"
+md5sums="5707d1a33fd234c3684aad4f3ec4d448 newt_syrup-0.2.0.tar.gz"
+sha256sums="27f34eaa54540adee5cdda95bd97d2af75a7eddcc303b4c73f36917f79e157e9 newt_syrup-0.2.0.tar.gz"
+sha512sums="9b6b1807585d58aaeca0d4783b3d2d643cdf8779acb5352b24128a59ed151f917ecf91d3f1da1d42f10350e8afed13d878e713329154a94a95c181733f393006 newt_syrup-0.2.0.tar.gz"